Linux Mint 19.3: beID & Belfius netbanking (2023)

Discussion:

Linux Mint 19.3: beID & Belfius netbanking

(te oud om op te antwoorden)

Jo

2020-01-11 19:11:57 UTC

Permalink

In de hoop dat er nog iemand is die deze groep volgt én raad weet...
De ondersteuning van W7 stopt binnenkort. Op zich geen ramp, ik kan daar
gewoon mee verder werken. Maar omdat banken vragen om de meest recente
versie van het OS te gebruiken ben ik op zoek naar alternatieven.
W10 is een alternatief, maar ik wil eerst andere mogelijkheden bekijken.
Bijvoorbeeld VirtualBox installeren op mijn W7 om Linux Mint te draaien
en daarmee netbanking te doen.
Ik wéét dat ik de Digipass kan gebruiken zonder hem in te pluggen, maar
dat is een heel gedoe. Ik wil die Digipass werkend krijgen onder LM. Het
enige wat ik tot nu toe kon vinden is een bericht uit 2014 dat stelt dat
de Digipass connecties heeft met M$ en dat die dus niet/nooit onder
Linux zal werken. Iemand die dit kan bevestigen of weerleggen? (Wine
vind ik ook geen optie.)
Tweede vraag: beID zou wél moeten werken, maar daarvoor wil ik diezelfde
Digipass gebruiken. Op de website staat software voor Linux Mint, maar
als ik dat probeer via een "live" USB, dan lukt het me niet. Ik
veronderstel dat dit te wijten is aan het gebrek aan ruimte op de
USB-stick. (?)

Mint onder Virtualbox lijkt me nogal omslachtig, en of het ook werkt zul
je moeten uitproberen. Misschien "zien" ze bij de bank dat je een
virtuele pc gebruikt en weigeren ze je dan te connecteren. Geen idee...

Zelf gebruik ik voor bankzaken al jaren een live-usb (vroeger Mint, nu MX
Linux met "persistence", zodat ik niet elke keer azerty moet instellen na
het booten) in combinatie met een draadloze digipass en dat werkt
uitstekend.

Trouwens heb ik nog nooit zo'n usb-digipass gezien, ik heb moeten
googlen naar een afbeelding. Hebben ze bij de bank (nog) geen draadloze
ter beschikking?

Wat je tweede vraag betreft: bedoel je dat je met een kaartlezer wilt
inloggen op overheidssites (zoals mycareer, mypension, selor etc.)?
Daarvoor gebruik ik ook Mint zonder probleem, in combinatie met de
ingebouwde kaartlezer in mijn toetsenbord, geen externe kaartlezer. De
middleware is makkelijk te installeren vanuit de repo van Mint zelf.

Dat MS Linux zou verhinderen om te werken lijkt me een fabeltje.

geedee

2020-01-11 20:06:05 UTC

Permalink

Vermits je werkte met W7 neem ik aan dat uw pc ook niet meer van de jongste is. Zo ook het geheugen. Om virtueel te werken moet je een grote hap van je geheugen prijs geven en dan werken beide besturingssystemen niet lekker. Een dual boot raad ik ook af want Win bezorgt je nachtmerries. Het beste is nog altijd één goed draaiend besturingssysteem. Ofwel doen zoals ik. Ik heb op een oude pc (>10 jaar) Mint geïnstalleerd. Draait prima. Met een HDMIswitch schakel ik vlot van de ene pc (W10) naar de andere. Uiteraard desktoppen.

s|b

2020-01-12 19:20:01 UTC

Permalink

Post by geedee
Vermits je werkte met W7 neem ik aan dat uw pc ook niet meer van de
jongste is. Zo ook het geheugen.

Win7 Home Premium x64 SP1, AMD A8-3870K Black Edition Quad-Core APU,
8 GiB RAM, Page File: 7,98 GiB, NTFS, Video adapter: ASUS Radeon HD 5450
(512MiB GDDR3), Screen: LCD 1920x1080x60Hz

Allemaal aangekocht in 2012. Maar mede dankzij die SSD draait W7 nog
altijd lekker. Als je M$ moet geloven, dan kan koop je best een nieuwe
PC samen met W10. Vind ik een beetje zonde.

Post by geedee
Om virtueel te werken moet je een grote
hap van je geheugen prijs geven en dan werken beide besturingssystemen
niet lekker.

Daar had ik eerlijk gezegd nog niet aan gedacht.

Post by geedee
Een dual boot raad ik ook af want Win bezorgt je
nachtmerries.

Ik heb daar vroeger wel eens voor gekeken, maar het leek me omslachtig.
Vandaar dat ik aan VirtualBox dacht.

Post by geedee
Het beste is nog altijd één goed draaiend
besturingssysteem. Ofwel doen zoals ik. Ik heb op een oude pc (>10 jaar)
Mint geïnstalleerd. Draait prima. Met een HDMIswitch schakel ik vlot van
de ene pc (W10) naar de andere. Uiteraard desktoppen.

Ik heb een oude PC (ouder dan 2012), met een oudere versie van Linux
Mint (Xfce). Dat bolt redelijk, maar die staat in een onverwarmde kamer.
In de zomer niet zo erg, in de winter iets minder (al duurt dat
netbanking wel niet lang).

--
Ik usenet, dus ik ben.
<http://www.briachons.org/>

Aragorn

2020-01-11 20:28:04 UTC

Permalink

Post by Jo
Dat MS Linux zou verhinderen om te werken lijkt me een fabeltje.

Vroeger was dat wel zo, onder Bill Gates en Steve Ballmer. Maar
Microsoft wordt nu al geruime tijd geleid door Satya Nadella, en die is
GNU/Linux en FLOSS in het algemeen veel gunstiger gezind.

Overigens, als een bepaalde technologie gestandardiseerd is, dan kan
GNU/Linux er sowieso mee werken. ;)

--
With respect,
= Aragorn =

Herman

2020-01-12 09:25:41 UTC

Permalink

In de hoop dat er nog iemand is die deze groep volgt én raad weet...
De ondersteuning van W7 stopt binnenkort. Op zich geen ramp, ik kan daar
gewoon mee verder werken. Maar omdat banken vragen om de meest recente
versie van het OS te gebruiken ben ik op zoek naar alternatieven.
W10 is een alternatief, maar ik wil eerst andere mogelijkheden bekijken.
Bijvoorbeeld VirtualBox installeren op mijn W7 om Linux Mint te draaien
en daarmee netbanking te doen.

Ik zou eerder suggereren om een dual boot te maken (als je schijfruimte
hebt, maar dat is met een Virtual Box niets anders. Zo kun je je stilaan
gewoon worden aan Linux, en kan je Windows na een tijd laten vallen (heb
ik jaaaaren geleden ook gedaan).

Ik wéét dat ik de Digipass kan gebruiken zonder hem in te pluggen, maar
dat is een heel gedoe. Ik wil die Digipass werkend krijgen onder LM. Het
enige wat ik tot nu toe kon vinden is een bericht uit 2014 dat stelt dat
de Digipass connecties heeft met M$ en dat die dus niet/nooit onder
Linux zal werken. Iemand die dit kan bevestigen of weerleggen? (Wine
vind ik ook geen optie.)

Ik heb dat een jaar of drie geleden ook ondervonden, en heb toen de
helpdesk van Belfius ingeschakeld. Zelfs al wist ik te vertellen dat hun
Vasco Digipass perfekt werkt onder Linux (bij mij Mageia), weigerden ze
pertinent dit als een item voor hun te beschouwen. In hun lastenboek stond
(staat nu nog???) niets over Linux suport. Het is zo dat als je naar een
site surft, je (zonder je er iets kunt aan doen) meegeeft aan die site
met welk sisteem je werkt. Zo zullen alle banken tegenwoordig wel Windows
XP afwijzen, en misschien binnenkort ook W7. Belfius weigert op die
manier alle Linux.

Tweede vraag: beID zou wél moeten werken, maar daarvoor wil ik diezelfde
Digipass gebruiken. Op de website staat software voor Linux Mint, maar
als ik dat probeer via een "live" USB, dan lukt het me niet. Ik
veronderstel dat dit te wijten is aan het gebrek aan ruimte op de
USB-stick. (?)

De beID werkt perfekt met de Vasco Digipass onder Mageia, geen enkel
probleem. Dus zie ik ook niet goed in waarom het niet zou werken onder
Mint, tenminste op een reële installatie. Ik heb in het verleden bij een
paar tests geregeld problemen ondervonden met USB onder Virtual Box, in
zoverre dat ik dat spoor heb opgegeven.
Wat die live USB betreft, dat heb ik nog nooit geprobeerd. Laat die versie
van de live (Min( veronderstel ik dan) toe van updates of toevoegingen
weg te schrijven naar de USB live stick???

Herman Viaene

Aragorn

2020-01-12 17:21:53 UTC

Permalink

Post by Herman

Ik wéét dat ik de Digipass kan gebruiken zonder hem in te pluggen,
maar dat is een heel gedoe. Ik wil die Digipass werkend krijgen
onder LM. Het enige wat ik tot nu toe kon vinden is een bericht uit
2014 dat stelt dat de Digipass connecties heeft met M$ en dat die
dus niet/nooit onder Linux zal werken. Iemand die dit kan
bevestigen of weerleggen? (Wine vind ik ook geen optie.)

Ik heb dat een jaar of drie geleden ook ondervonden, en heb toen de
helpdesk van Belfius ingeschakeld. Zelfs al wist ik te vertellen dat
hun Vasco Digipass perfekt werkt onder Linux (bij mij Mageia),
weigerden ze pertinent dit als een item voor hun te beschouwen. In
hun lastenboek stond (staat nu nog???) niets over Linux suport. Het
is zo dat als je naar een site surft, je (zonder je er iets kunt aan
doen) meegeeft aan die site met welk sisteem je werkt. Zo zullen alle
banken tegenwoordig wel Windows XP afwijzen, en misschien binnenkort
ook W7. Belfius weigert op die manier alle Linux.

Dat komt door de User-Agent van de browser, ook bekend als "browser
identification string". Die is makkelijk te wijzigen via the
"about:config" [*], en het is zelfs zo dat de allernieuwste Firefox
standaard "browser fingerprinting protection" aan heeft staan, wat er
op neer komt dat Firefox 72 zich aan ELKE site zal aanmelden als
"Firefox op Windows 10", ook al draait hij op GNU/Linux.

[*] Open een nieuwe tab en typ in de adresbalk "about:config", en druk
op de Enter-toets. Je krijgt een waarschuwing te zien. Negeer die.
In het zoekveld dat nu verschijnt typ je het volgende (zonder
aanhalingstekens):

"general.useragent.compatMode.firefox"

Er verschijnt een parameter met die string daarin, en met de waarde
"false". Dubbelklik die parameter en de waarde zal nu veranderen
naar "true".

Maak het zoekveld leeg en typ nu de volgende string in datzelfde
zoekveld (zonder aanhalingstekens):

"general.useragent.override.addons.mozilla.org"

Ook nu verschijnt de juiste parameter, maar in dit geval is het een
tekst-string in plaats van een boolean. Beweeg de muisaanwijzer nu
naar de rechterkant van de parameter, en je zult een icoontje van
een potlood zien verschijnen. Klik daarop, en dan kan je nu de
waarde van de parameter veranderen. Verander dat in het volgende,
zonder aanhalingstekens...:

"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101
Firefox/68.1.0esr"

--
With respect,
= Aragorn =

s|b

2020-01-12 19:31:27 UTC

Permalink

Post by Herman
Ik zou eerder suggereren om een dual boot te maken (als je schijfruimte
hebt, maar dat is met een Virtual Box niets anders. Zo kun je je stilaan
gewoon worden aan Linux, en kan je Windows na een tijd laten vallen (heb
ik jaaaaren geleden ook gedaan).

Ik dacht aan VirtualBox, omdat het wisselen tussen de verschillende
besturingssystemen dan sneller zou (?) gaan. Ik gebruik Firefox,
Thunderbird en LibreOffice en ik weet dat dat allemaal mooi draait onder
Linux, maar ik heb een heleboel freeware die ik niet graag opgeef. Een
deel zal wel werken onder Wine, maar dat is een beetje te gek:
overstappen naar Linux om daaronder Windows programma's te draaien. Nu,
dat is een andere discussie. :-)

Post by Herman
Ik heb dat een jaar of drie geleden ook ondervonden, en heb toen de
helpdesk van Belfius ingeschakeld. Zelfs al wist ik te vertellen dat hun
Vasco Digipass perfekt werkt onder Linux (bij mij Mageia), weigerden ze
pertinent dit als een item voor hun te beschouwen. In hun lastenboek stond
(staat nu nog???) niets over Linux suport. Het is zo dat als je naar een
site surft, je (zonder je er iets kunt aan doen) meegeeft aan die site
met welk sisteem je werkt. Zo zullen alle banken tegenwoordig wel Windows
XP afwijzen, en misschien binnenkort ook W7. Belfius weigert op die
manier alle Linux.

Dus er is wel degelijk iets van aan dat Belfius geen support voor Linux
aanbiedt. :-\

Op hun site staat dit te lezen over W7:
<https://www.belfius.be/retail/nl/zelf-bankieren/internet-mobile/belfius-direct-net/browser/index.aspx>

<quote>

Microsoft deelde mee dat het Windows 7 niet meer ondersteunt vanaf 14
januari 2020. Belfius zet de technische ondersteuning voor Windows 7 dus
ook stop. Microsoft raadt u aan om voor januari 2020 over te stappen
naar Windows 10. Het blijft wel mogelijk om u aan te melden op Belfius
Direct Net en onze website te bekijken.

Microsoft stopt ook met de ondersteuning van en security-updates voor
Internet Explorer 11. Stap dus best zo snel mogelijk over op Google
Chrome of Mozilla Firefox om u aan te melden op Belfius Direct Net of
onze website te bekijken. In de loop van 2020 zal u dat om
veiligheidsredenen niet meer kunnen doen met Internet Explorer 11.

</quote>

Beetje dubbelzinnig: geen technische ondersteuning voor W7, maar je kan
wel nog aanmelden op Belfius Direct Net?

Post by Herman
De beID werkt perfekt met de Vasco Digipass onder Mageia, geen enkel
probleem. Dus zie ik ook niet goed in waarom het niet zou werken onder
Mint, tenminste op een reële installatie. Ik heb in het verleden bij een
paar tests geregeld problemen ondervonden met USB onder Virtual Box, in
zoverre dat ik dat spoor heb opgegeven.

Dat klinkt niet hoopgevend. Maar ik denk dat ik op mijn andere (oude) PC
eens een nieuwe installatie zal doen om dan zelf eens te kijken.

Post by Herman
Wat die live USB betreft, dat heb ik nog nooit geprobeerd. Laat die versie
van de live (Min( veronderstel ik dan) toe van updates of toevoegingen
weg te schrijven naar de USB live stick???

Ik dacht van wel, maar ik kreeg melding dat er geen plaats was of iets
dergelijks. Het was dan ook maar een stick van 4 GB, leuk voor Tails
live op te starten, maar verder...

--
Ik usenet, dus ik ben.
<http://www.briachons.org/>

s|b

2020-01-12 19:14:05 UTC

Permalink

Post by Jo
Trouwens heb ik nog nooit zo'n usb-digipass gezien, ik heb moeten
googlen naar een afbeelding. Hebben ze bij de bank (nog) geen draadloze
ter beschikking?

Het is een Digipass 870. Vroeger waren die verbonden met vasco.com, maar
dat linkt nu door naar onespan.com. Deze is het:

<https://www.onespan.com/products/card-readers/digipass-870>

De draadloze versie bestaat al langer dan vandaag, maar die wil ik niet.
Dat is me te veel gedoe met die codes allemaal. Via USB verbonden werkt
allemaal véél sneller.

Post by Jo
Wat je tweede vraag betreft: bedoel je dat je met een kaartlezer wilt
inloggen op overheidssites (zoals mycareer, mypension, selor etc.)?
Daarvoor gebruik ik ook Mint zonder probleem, in combinatie met de
ingebouwde kaartlezer in mijn toetsenbord, geen externe kaartlezer. De
middleware is makkelijk te installeren vanuit de repo van Mint zelf.

Ik heb het op een oudere versie geprobeerd (18.x?) , geïnstalleerd op
een andere PC, met de download op deze pagina:

<https://eid.belgium.be/en/linux-eid-software-installation>

Daarna kreeg ik melding dat ik via apt-get en apt-get update moest
installeren, maar dat lukte me niet.

Post by Jo
Dat MS Linux zou verhinderen om te werken lijkt me een fabeltje.

Dat is niet wat er stond. In het bericht stond dat de Digipass verbonden
zou zijn aan M$ en dat er daarom geen ondersteuning voor Linux zou
komen.

--
Ik usenet, dus ik ben.
<http://www.briachons.org/>

marc

2020-01-19 23:51:28 UTC

Permalink

Ik wéét dat ik de Digipass kan gebruiken zonder hem in te pluggen, maar
dat is een heel gedoe. Ik wil die Digipass werkend krijgen onder LM. Het
enige wat ik tot nu toe kon vinden is een bericht uit 2014 dat stelt dat
de Digipass connecties heeft met M$ en dat die dus niet/nooit onder
Linux zal werken. Iemand die dit kan bevestigen of weerleggen? (Wine
vind ik ook geen optie.)

https://www.eidshop.be/a-54499119/eid-kaartlezer/onespan-digipass-905-basic/

"Ik ga het op een dag nodig hebben,
bid voor mij ..."

--
--
What's on Shortwave guide: choose an hour, go!
http://shortwave.tk
700+ Radio Stations on SW http://swstations.tk
300+ languages on SW http://radiolanguages.tk

Jo

2020-01-20 05:53:36 UTC

Permalink

Post by marc

Ik wéét dat ik de Digipass kan gebruiken zonder hem in te pluggen, maar
dat is een heel gedoe. Ik wil die Digipass werkend krijgen onder LM.
Het enige wat ik tot nu toe kon vinden is een bericht uit 2014 dat
stelt dat de Digipass connecties heeft met M$ en dat die dus niet/nooit
onder Linux zal werken. Iemand die dit kan bevestigen of weerleggen?
(Wine vind ik ook geen optie.)

https://www.eidshop.be/a-54499119/eid-kaartlezer/onespan-digipass-905-

basic/

Post by marc
"Ik ga het op een dag nodig hebben,
bid voor mij ..."

Of koop gewoon een toetsenbord met ingebouwde kaartlezer. Werkt prima,
zowel met Windows als met Linux.

https://www.codima.be/cherry-kc-1000-sc-black-eid-azerty-be

s|b

2020-01-22 18:40:58 UTC

Permalink

Post by marc
https://www.eidshop.be/a-54499119/eid-kaartlezer/onespan-digipass-905-basic/
"Ik ga het op een dag nodig hebben,
bid voor mij ..."

Het gaat in mijn geval om de Digipass 870 en eID zou geen probleem zijn.
Netbanking terwijl de Digipass met USB verbonden is wél.

--
Ik usenet, dus ik ben.
<http://www.briachons.org/>

Top Articles
Latest Posts
Article information

Author: Nicola Considine CPA

Last Updated: 02/13/2023

Views: 5614

Rating: 4.9 / 5 (49 voted)

Reviews: 88% of readers found this page helpful

Author information

Name: Nicola Considine CPA

Birthday: 1993-02-26

Address: 3809 Clinton Inlet, East Aleisha, UT 46318-2392

Phone: +2681424145499

Job: Government Technician

Hobby: Calligraphy, Lego building, Worldbuilding, Shooting, Bird watching, Shopping, Cooking

Introduction: My name is Nicola Considine CPA, I am a determined, witty, powerful, brainy, open, smiling, proud person who loves writing and wants to share my knowledge and understanding with you.